Sign In | Join Free | My benadorassociates.com
benadorassociates.com
Products
Search by Category

umbrella with light

All umbrella with light wholesalers & umbrella with light manufacturers come from members. We doesn't provide umbrella with light products or service, please contact them directly and verify their companies info carefully.

Total 449 products from umbrella with light Manufactures & Suppliers
Quality Charming Garden UV Beach Umbrella Led Lights Polyester Fabric Aluminum Shaft for sale

Brand Name:UP

Model Number:UP-B010

Place of Origin:Fujian,China

...Umbrella Led Lights Outdoor Parasol Umbrella This charming umbrella with warm white LED rib which will light or a distinctive central hub light, or both together. It is powered by a solar rechargeable battery. aluminum center pole and steel ribs make it strong and durable.the size is 34 inch , and the open diameter is 150cm. Product name Hot Sale Patio Umbrella Led Lights Outdoor Parasol Umbrella...

Xiamen United-Prosperity Industry & Trade Co., Ltd.
Verified Supplier

Fujian

Quality 23 Inch Black Straight Handle Manual Open Umbrella With Light Tips And Top for sale

Brand Name:GoodPartner

Model Number:NU1911053

Place of Origin:China

23 Inch Manual Black Straight Handle Umbrella With Light Tips And Top Products Advantages Strong windproof: fiberglass frame and fiberglass ribs Suitable for dark night Durable pongee fabric Application Widely used in rainy&snowy&sunny days, traveling, ...

Xiamen GoodPartner Umbrella Co., Ltd
Active Member

Fujian

Quality Capsule black plastic umbrella ultra light mini pocket sun umbrella for advertising gift for sale

Brand Name:GIVEBEST

Model Number:GB-1012

Place of Origin:CHINA

Capsule black plastic umbrella ultra light mini pocket sun umbrella for advertising gift Name capsule umbrella usage promotional gifts weight 320g size 19*5cm folded size Product pictures:

Suzhou Givebest Import & Export Co., Ltd
Active Member

Jiangsu

Quality Patio Umbrellas 9' Light Beige, Outdoor Umbrella Market Table Umbrellas with Push Button Tilt and Crank for sale

Brand Name:BAGPLASTICS@VIP.163.COM

Model Number:WHATSAPP:+8613780964661

Place of Origin:CHINA

Outdoor Umbrella Market Table Umbrellas with Push Button Tilt and Crank for Lawn, Garden, Deck, Backyard & Pool (Grey, 6.6 * 10 ft) PLEASE INQUIRY US BAGPLASTICS@GMAIL.COM 100% Fabric polyester, waterproof, products-supplies.com UV protection, high-quality...

YANTAI BAGEASE PRODUCTS SUPPLIES MANUFACTURING CO.,LTD.
Site Member

Quality Outdoor  Steel Umbrella with Light for sale

Place of Origin:other

Brand Name:HIFINE

Model Number:HFU-602

Product Description garden umbrella Product Name 3.0M Hanging Umbrella Style Brand hifine Colour red,black Texture Place of Product zhejiang Province,China Fabric 180G Modes of packing Packed in one carton Size 3.0M After sale service 3.0M Steel Hanging ...

jiaxing hifine international enterprise co ltd
Verified Supplier

Zhejiang

Quality 8.5 ft Durable Stainless Steel Pole White Umbrella Pagoda Light Weight Pagoda Outdoor Umbrellas Parasol for sale

Categories:Central pole umbrella parasol

Country/Region:china

Key attributes Industry-specific attributes application Home Office, Outdoor, Hotel, Office Building, Sports Venues, Leisure Facilities, Park, Courtyard, Exterior, Garage & Shed, Gym, Villa design style Contemporary type Umbrella Other attributes mail ...

Foshan Yoshen Outdoor Furnishing Co.,Ltd
Site Member

Guangdong

Quality Factory price Luxury Wind-Resistant Roman Umbrella with Lighting for sale

Brand Name:Roman Umbrella

Model Number:Roman Umbrella

Place of Origin:China

Outdoor sunshade umbrella , courtyard umbrella , villa umbrella , open-air garden umbrella Products Description Product Name: garden umbrella outdoor with led Fabric: Osbur Pole Material: Aluminium Alloy Place of Origin Guangdong Province,China Brand name ...

Guangdong Aikeli Intelligent Technology Co., Ltd.
Verified Supplier

Guangdong

Quality Nordic Origami Bedside Lamp Pleated Umbrella Table Light Vintage Minimal Lamps for sale

Brand Name:GRH

Model Number:GRH-E001,GRH-RFC1004,GRH-RFC1005,GRH-RFC1011

Place of Origin:CHINA

Nordic Style Origami Bedroom bedside Table Lamp Pleated Umbrella Table light Vintage Minimal Lamps Product Description: Product name Squiggle Table Lamp Style Nordic style Brand name GRH Color Beige, White, Dark green, Black Material Metal, Fabric Place...

WENZHOU GRH MANUFACTURE CO.,LTD
Verified Supplier

Zhejiang

Quality Scandinavian Lights Katana Umbrella LED Lights Samurai Sword Design 190T Nylon Fabric for sale

Place of Origin:Fujian, China

Brand Name:YLF

Model Number:YLF

#detail_decorate_root .magic-0{border-bottom-style:solid;border-bottom-color:#53647a;font-family:Roboto;font-size:24px;color:#53647a;border-bottom-width:2px;padding-top:8px;padding-bottom:4px}#detail_decorate_root .magic-1{width:750px}#detail_decorate_root...

Jinjiang YLF Umbrella Co., Ltd.
Verified Supplier

Fujian

Quality Customized Color Garden Umbrella with Light Waterproof Commercial Restaurant Cantilever for sale

Place of Origin:Zhejiang, China

Model Number:AJ-GU-016

#detail_decorate_root .magic-0{border-bottom-style:solid;border-bottom-color:#53647a;font-family:Roboto;font-size:24px;color:#53647a;font-style:normal;border-bottom-width:2px;padding-top:8px;padding-bottom:4px}#detail_decorate_root .magic-1{width:750px;...

Ningbo Aj Union Imp.& Exp. Co., Ltd.
Verified Supplier

Zhejiang

Quality Outdoor Cafe Villa Pool Side Umbrella with Lighted Handle and 38mm Aluminium Pole for sale

Place of Origin:Guangdong, China, Guangdong China

Brand Name:Changsheng

Model Number:CS047

#detail_decorate_root .magic-0{border-bottom-style:solid;border-bottom-color:#53647a;font-family:Roboto;font-size:24px;color:#53647a;font-style:normal;border-bottom-width:2px;padding-top:8px;padding-bottom:4px}#detail_decorate_root .magic-1{margin-bottom:...

Foshan Woderful furniture Co., Ltd.
Verified Supplier

Guangdong

Quality Light Blue Double Layer Reverse Umbrellas 105cm Auto Open Close Inverted Umbrella for sale

Brand Name:FULL

Model Number:FAN-038

Place of Origin:China

Automatic Close Reverse Umbrella | Light Blue Double Layer Rose Design Redefine Dry & Stylish Rainy Days This automatic closing reverse umbrella in light blue with double-layer rose pattern vents and curved handle elevates your rainy day experience. We've ...

Shenzhen Fxinda Umbrella Company Limited
Verified Supplier

Guangdong

Quality Light Blue Quality Children Gift Umbrella for sale

Place of Origin:Xiamen, China

Brand Name:WINTOP

Model Number:WTG026

... : Reach, En71, Azo, Upf Minimum Order Quantity : 3600PCS Terms of Payment : 30% Deposit, Balance Tt Before Shipping Light blue quality children gift umbrella 1. Light blue quality children gift umbrella 2. Auto open Mechanism 3

XIAMEN WINTOP IMP. AND EXP. CO., LTD
Active Member

Fujian

Quality Aluminum 360 Degree Rotating Roman Umbrella Adjustable With LED Lights for sale

Model Number:1151.130

Place of Origin:China

...Umbrella With LED Lights Produce Description Product Name: 3x4M Aluminum Hole Adjustable 360° rotation rechargable LED Roman Umbrella Size: 300x400xH260cm Pole: Alu. 77x53mm Ribs: 8pcs, 14*24mm with LED light Fabric: 250G polyester with PA coating, with window hole, with strap Feature Crank to open and close; Waterproof and UV-resistant; 360° pedal rotation; Six-hole umbrella...

Ningbo Walkingworld Leisure Products Co.,Ltd
Active Member

Zhejiang

Quality Windproof Flat Lightweight Folding Umbrella 5 Section Aluminum Frame Shaft for sale

Brand Name:TOKO

Model Number:MN009

Place of Origin:China

... handle 6, 60 days quick delivery Mini compact folding umbrella which is suitable for women and can put it in the bag. Our strong aluminum frame can be windproof and lightweight. It can also protect the sunshine because of the black UV protection. If

Xiamen Toko Umbrella Co.,Ltd.
Active Member

Fujian

Quality Ultraviolet Light Discoloration Compact Pocket Umbrella 42 Inch Arc 7 Ribs for sale

Brand Name:Neutral

Model Number:DZY-M0002

Place of Origin:China

... to ultraviolet light. Watch the magic Ink transform into colorful dots before your eyes as it meets UV light. Take the umbrella away from sun light the colors return to white, allowing you to enjoy the transformation time and time again A protective,

DNJ Trading (Shenzhen) Co., Ltd.
Active Member

Guangdong

Quality Toothed Iron Photography Adapters,Swivel Or Adjustable-Head,7/8mm Umbrella Receptacle for sale

Brand Name:HAFE

Model Number:TM11 Series

Place of Origin:China

...Umbrella Receptacle, Matte Black, Universal Light Fixture Mount for Studio/On-Location Lighting Setups (Weight: 0.18-0.37kg) The TM Series encompasses toothed iron umbrella adapters and adjustable-head adapters—specialized photography accessories engineered to enable flexible, secure connections between lighting equipment and umbrella

Hafe International Limited
Verified Supplier

Hong Kong

Quality Outdoor Funiture Color Customized 2.7M Hand Crank Sunshade with Led Light Iron Umbrella for sale

Place of Origin:Zhejiang, China

Model Number:BLIU05

Large Leisure Stable Structure Garden Umbrella Color Customized 2.7M Outdoor Hand Crank Sunshade with Led Light Iron Umbrella Product Description Product name Outdoor Umbrella Brand Name Customized Model Number BLIU05 Ribs 8pcs, Iron Ribs Stand pole:48/...

Yuyao Believe Leisure Products Co., Ltd.
Verified Supplier

Zhejiang

Inquiry Cart 0
  • Haven't found right suppliers
  • Our buyer assistants can help you find the most suitable, 100% reliable suppliers from China.
  • And this service is free of charge.
  • we have buyer assistants who speak English, French, Spanish......and we are ready to help you anytime!
Submit Buying Request